Created using
htm2chm 3.0

Download it NOW!


Менеджер файлов - NKFM

Менеджер файлов - NKFM. Работа в программе

(Из рубрики: Начинающим о компьютерных технологиях. Автор - NK) nk-inform.narod.ru

Зачем еще один менеджер файлов? Разве их недостаточно: Проводник, TotalCommander, Far? Ну, что ж, давайте разберемся.

После запуска Проводника мы видим в левой части окна список, который не отражает фактическую файловую структуру. Самый первый вопрос: что со всем этим делать. Обращение к меню никак не проясняет ситуацию.
Главным достоинством двухоконных менеджеров файлов является наглядность операции копирования и переноса (откуда и куда). Но, в большом ряде случаев, два окна со списком файлов - нерациональная избыточность, а также попытка "улучшить" DOS-шедевр Питера Нортона.

Фундаментальное определение: (можно пропустить)

Вся информация в компьютере хранится на дисках в виде файлов. Файлы для удобства могут быть собраны в папки (каталоги, директории). Файловая структура на дисках имеет древовидную форму: в папках могут располагаться другие папки и файлы и так далее. На расположение файла или папки в файловой структуре указывает путь (маршрут) к данному объекту.

Посмотрим на менеджер файлов NKFM.

- Левое окно сразу показывает список дисков данного компьютера. (Вся информация компьютера хранится на дисках).
- Выбор диска разворачивается в показ его древовидной файловой структуры. (Структура папок на дисках имеет древовидную форму)
- В правом окне разворачивается список папок и файлов, внутри той, которая выбрана слева. (Вся информация в компьютере хранится в виде файлов, которые для удобства помещаются в папки).
- В самом верху окна выводится путь к данной рабочей папке, а в левом окне отображается ее положение на дереве файловой структуры диска. Путь или маршрут к папке или файлу это список папок, включающий название диска, который нужно пройти, открывая папки, чтобы нам стал доступен нужный файл или папка. Доступность означает, что папку или файл можно выбрать для работы. Что, сложновато? Но это очень важно, как адрес вашего места жительства, потому и в самом верху.
- В правом окне мы имеем список папок и файлов внутри выбранной в левом окне с их основными характеристиками. (Файл - блок данных на диске обозначенный именем. Основные характеристики: Имя, размер, дата создания, тип, атрибуты).
- Менеджер файлов помогает с файлами и папками выполнять операции которые обозначены кнопками в правой части окна программы. (Файлы можно: создавать, просматривать, изменять(редактировать), копировать, перемещать, переименовывать).
- Наглядность копирования и перемещения файлов реализована в программе NKFM наличием двух панелей со списками файлов и папок: вторая может открываться или убираться. (При копировании и переносе необходимо выбирать объекты (файлы и папки) на источнике и указывать приемник этих данных - куда они будут помещаться).
- Управление списками на панелях производится кнопками, которые расположены слева на панели инструментов.
Список с нижней панели на верхнюю
Список с верхней панели на нижнюю.
Обменяться списками между панелями.
- Свободное пространство на диске и объем копиркуемой и перемещаемой информации наглядно отображаются.
- Менеджер NKFM сохраняет функциональность Проводника. Нажмите на выбранном объектке правую кнопку и в контекстном меню выберите необходимую операцию с ним, которую обеспечивает операционная система.
- При обилии информации NKFM поможет в поиске нужного файла по большому количеству критериев - кнопка "Искать".
- В менеджере файлов NKFM реализован просмотр содержимого файлов любого размера в наиболее употребимых кодировках (WIN, DOS, UNICODE). Окно просмотра удобно располагается справа от программы и открывается или убирается кнопкой [<>].
- Встроенный просмотрщик поддерживает просмотр распространенных форматов изображений (BMP, JPG, GIF, PNG, WMF, ICO).
- При потребности в ручном формировании команд запуска программ используй "Выполнить". Ctrl-J - команда в строку из списка.
- Несколько шелчков и движений мышью и мы имеем привычные два окна, но расположить мы их можем, однако же, как захотим.

Краткая информация для использования программы "Менеджер файлов NKFM".

- Выберите диск из списка левого окна или из выпадающего списка дисков.
- Общий объем и наличие свободного пространства на выбранном диске отображаются.
- Выбор необходимой папки можно производить, как в левом так и в правом окне. При работе с правой панелью левая отслеживает положение выбранной папки.
- Над выбранным файлом или группой можно выполнить файловую операцию, нажав кнопку на правой панели или соответствующую ей функциональную клавишу.

F2 - Переименовать (Изменить имя папки или файла)
F3 - Просмотреть содержимое файла в текстовом или шестнадцатеричном виде, а поддерживаемые картинки в виде изображений.
F4 - Загрузка файла для редактирования (не пытайтесь редактировать нетекстовые файлы их можно повредить).
Shift + F4 - Создание нового текстового файла.
F5 - Копирование файла, папки или смешанной группы. Группа для файловой операции может быть выбрана несколькими способами.
Пробел - выделение объекта без перемещения указателя.
Insert - выделение объекта с перемещением указателя.
+ (Плюс) - Выделение объектов с использованием обобщающих символов ? и *
- (Минус) - Отмена выделения с использованием обобщающих символов.

F6 - Перенос (перемещение) файла. папки или группы
F7 - Создание папки (каталога).
F8 - Удаление объекта или группы в корзину или безвозвратно.

Другие функциональные клавиши

F9 - Задание особых настроек:
1. Внешний просмотрщик для текстов.
2. Внешний просмотрщик для изображений.
3. Внешний редактор текстов (Если вы не хотите использовать Блокнот).
4. Установка размера шрифта панелей списков.

F10 - Выбор программ для открытия файлов с соответствующими расширениями (Вспомните, как Windows упорно загружает файл в программу известную только ему самому, скрывая настройку где то в гуще своих дебрей). (Настройка действует только при работе с NKFM)

- Двойной щелчек левой кнопкой мыши на выбранном элементе означает его открытие программой согласно его расширения, либо выполнение, если это программа, либо открытие списка содержимого, если это папка.
- Переход в папку предыдущего уровня можно выполнить, щелкнув кнопку-указатель на панели инструментов или, нажав кнопку BackSpace (стрелка влево) на клавиатуре.
- Менеджер NKFN автоматически не корректирует список дисков на левой панели в случае активации новых (flash, сетевые) из-за медленного выполнения системой данной операции для не очень новых компьютеров. Для обновления списка дисков на левой панели нажмите вторую кнопку на панели инструментов. (Список дисков на панели инструментов обновляется автоматически).
- Для выполнения операции копироваеия или переноса необходимо открыть вторую панель кнопкой. Этой же при ненужности ее можно и свернуть.
- Для удобства все элементы снабжены всплывающей подсказкой: подведите к нему указатель мыши.
- Список в правом окне может быть отсортирован: по имени (по умолчанию), по размеру, по дате, по типу. Щелкните по заголовку соответствующей колонки. Активность сортировки отражается "галочкой".

- Списками на правой и нижней панелях можно управлять кнопками.
Реакции кнопок:
Список с нижней панели на верхнюю
Список с верхней панели на нижнюю.
Обменяться списками между панелями.

- Остальные кнопки на панели:

- Выйти из программы (должна быть всегда под рукой).
- Принудительно обновить список дисков и папок левой панели (В операционной системе могут монтироваться новые диски (флеш, сетевые), создаваться новые папки. Структура дерева файловой системы актуальна только сразу после обновления.)
- Открыть или закрыть дополнительную панель со списком папок и файлов (Если вы не собираетесь выполнять операции копирования и переноса, то она может быть закрыта).
- Свернуть или развернуть левую панель дерева файловой структуры (Правая панель со списком папок и файлов полностью функциональна, включая выбор рабочего диска).
- Кнопка перехода на один уровень в файловой стркутуре (переход в верхнюю папку, можно использовать клавишу <- BackSpace)
- Кнопка показа-скрытия панели просмотра файлов [<>]. На мониторах с широким экраном есть много места для удобного просмотра файлов изображений или содержимого файлов в текстовом или шестнадцатеричном виде.
- Кнопка информации о программе.

Программа оперативно информирует пользователя о выполняемых операциях и о событиях в системе: смена дискового носителя, изъятии диска, монтировании новых дисков.

Из NC и клонов.

- Shift+F4 - Создает новый текстовый файл в текущей папке.
- Ctrl-J - Помещает выделенный элемент списка в поле "Выполнить" - аналог командной строки.

Важные особенности:

- Программа NKFM использует настройки системы для вывода расширений файлов или их скрытия. Для выбора нужного вам режима воспользуйтесь настройкой вида отображения папки в системе. Для XP: Мой компьютер-Сервис-Свойства папки-Вид-Скрывать расширения для зарегистрированного типа файлов. Политика фирмы Майкрософт - не заострять внимание пользователя на расширении файла, так как, фактически, оно не определяет однозначно его тип. Вопрос остается спорным и, поэтому, показывать расширения или нет решаете вы.
- Программа NKFM показывает ZIP-файлы (упакованные архивы файлов), как папки, но использовать файлы внутри их пока не позволяет. Работайте с архивами, используя программы WinZip, WinRAR и тд.
- В некоторых операционных системах просмотр структуры CD (DVD) дисков может ограничиваться списком папок корневого каталога (фокусы ОС). Выбирайте папки в правом окне.
- Встроенный просмотрщик поддерживает корректное отображение кодировки UNICODE только для русского языка.
- Вторая, дополнительная панель со списком формируется классическим способом и если в папке несколько тысяч файлов то задержка при формировании списка будет значительной.

P.S.

Конечно же творение учителя информатики не может конкурировать по возможностям и функциональности с элитой файлового менеджмента обозначенной в самом начале, но я и не ставил такой задачи. Моя цель: показать начинающим устройство файловой системы компьютера и научить полноценно ее использовать себе во благо.
Если проще: не пристало насущные потребности простого пользователя демонстрировать на примерах платных навороченных программ, мы и сами могем...

Буду рад, если моя программа поможет вам в освоении современных компьютерных технологий. Отзывы, пожелания и конструктивная критика приветствуется.

Автор программы NKFM - Коротков Николай
Мой E-mail : kornil1956@rambler.ru

Мои сайты:
 http://nk-inform.narod.ru
http://navoloky.narog.ru


Работа с файлами в программе NKF

Работа с файлами в программе NKFM. Описание программы

(Из рубрики: Начинающим о компьютерных технологиях. Автор - NK) nk-inform.narod.ru

Вот вы читаете эти строки, а это означает, что вы хотите узнать про возможности компьютера, как можно больше. Если вы уже умеете кликать (щелкать) по ярлыкам, пунктам меню и набирать текст, то пора переходить в следующую группу пользователей, к которой относятся те, кто знает, что такое файл и как устроена файловая система (как файлы хранятся на дисках).
Кратко объясню почему это так важно. Если вы начинаете понимать, что картинки, музыка, фильмы хранятся в виде файлов. И, что ярлычки на экране вашего компьютера, и все, до одной, программы это тоже файлы. И, что вирусы, троянские программы, разные агенты, шпионы и вымогатели прячут себя в файлах, то с этого самого момента кончается власть компьютера над вами и начинается ваша над ним.
Зная устройство файловой системы, вы уже не позволите кому угодно бесконтрольно использовать дисковое пространство вашего компьютера и всегда сможете проверить, а чем же на самом деле забита его память.
Преподавая информатику в школе, всегда сталкивался с проблемой: как просто и доступно объяснить устройство файловой системы компьютера. В один прекрасный момент я понял: лучше один раз увидеть...
Для работы с файловой системой люди изобрели специальные программы: менеджеры файлов. Мне довелось использовать больше десятка. Самые распространенные: двухоконные. Изобретение Питера Нортона: Norton Commander можно считать гениальным, НО... Данная программа предполагает, что вы уже знаете, как устроена файловая система, а начинающего два окна с обилием иностранных символов, чисел, значков просто ставят в тупик.

При создании своей программы для работы с файлами, я, в первую очередь, думал о максимально быстром закреплении в сознании начинающего пользователя базовых понятий и практических навыков для работы с файловой системой компьютера. Но пора от слов перейти к делу: вперед!

Вся информация в компьютере хранится на дисках. Файловый менеджер сразу должен показывать диски компьютера.

На дисках информация хранится в виде файлов. Файл это блок цифровых данных (на компьютере все закодировано (преобразовано) в цифровой вид), который находится на диске и ему (блоку) присвоено имя. Это означает, что, выбрав диск из списка, мы должны увидеть файлы, которые на нем находятся, верно? Без сомнения!

Как вы понимаете, файлов может быть много. Хорошо, если их 10 или 20, а если их 1000 или 5 тысяч? Попробуйте просто сосчитать до тысячи, что долго? Нужно такое изобилие как то упорядочить.

Придумали размещать файлы в папках. Выбираем диск компьютера и видим список папок, в которых размещаются файлы, ну и сами файлы мы на диске тоже можем видеть, если они там есть.
Но, если этих самых файлов много, то их лучше размещать в папках. Файлы относящиеся к операционной системе в папке Windows, а в какой же еще. Файлы игрушек, в папке ИГРЫ. Фильмы в папке ФИЛЬМЫ. Музыка в папке МУЗЫКА. Фото, ну вы уже поняли...

Интересно то, что внутри папок могут располагаться не только файлы, но и папки, и внутри их тоже и так далее. Вот и говорят: файловая структура имеет древовидную форму. То, что мы видим выбирая (открывая) диск, называется главной или корневой папкой. И в самом деле, раз дерево, значит должен быть и корень. Вместо названия "Папка" можно встретить другие: Каталог или Директорий. Будем пока считать, что эти термины равнозначны. Я буду применять их все, чтобы вы быстрей к ним привыкли.

Итак, мы выбрали диск и видим список папок и файлов, которые находятся в главном (корневом) каталоге. Если мы откроем какую либо из папок то мы увидим список папок и файлов, находящихся именно в той, которую открыли. Мы можем продолжить открывать папки, чтобы заглянуть во все и выяснить: что же в этих папках хранится.

Теперь нам стало понятно: главный каталог это корень дерева или можно сказать ствол. А вот от корня-ствола растут другие ветки-папки, а от них другие. А на этих ветках (в папках) размещаются листочки-файлы. Могут ли листочки располагаться на стволе: могут. Но лучше не засорять корневой каталог файлами, а располагать их в папках по темам: Документы, фотографии, музыка и тд.

Зачем нужен менеджер файлов, если их можно обслуживать и в специальных программах для работы с музыкой, картинками, документами, да можно, НО... Файловый менеджер позволяет вам перемещаться по папкам без всяких ограничений. Видеть все папки и все файлы, независимо от их типа. Файловый менеджер позволяет сделать с файлом и папкой все, что разрешает операционная система.

Посмотрите на файловый менеджер NKFM. Он простой, наглядный и удобный, так что 'самому начинающему пользователю после его запуска сразу же становится ясно, где здесь диски, где папки, где файлы, и уже пора со всем этим начинать что то делать. Ну что ж, начнем.

После запуска программы мы можем видеть в левом окне список дисков, а в правом список папок и файлов выбранного диска. При первом запуске в правом окне будет развернут список папок и файлов корневой папки диска С, если, конечно, такой на компьютере имеется.

Диски, которые мы можем видеть в левом окне называют логическими. В компьютере может быть один жесткий диск, но, для удобства его часто разбивают на несколько логических разделов: один раздел для операционной системы (главной управляющей программы), а другие, например, для программ, для мультимедиа-файлов (фильмов, клипов музыки), и так далее.

В качестве дисков в списке могут присутствовать:
- дискеты - устаревшие гибкие диски,
- жесткий диск (его логические разделы),
- CD-DVD - диски,
- Флеш-диски,
- сетевые - расположены на других компьютерах,
- память сотовых телефонов, плейеров, цифровых фотоаппаратов и еще некоторых устройства, которые операционная система обнаруживает, как диски.

Диски обозначаются буквами латиницы с двоеточием. Вы не запутаетесь, когда увидите: A: - это, обычно, дискета. С: - это, обычно, жесткий диск.

После буквы с двоеточием идет значок обратной дроби - \ . Он указывает на то, что мы имеем дело с папкой. Если мы видим надпись: C:\ - то это указывает на корневой каталог диска C.
Чтобы не спутать название папки с файлом ее всегда закрывают значком \.
- Итак D:\TEST\ - папка TEST в корневом каталоге диска D.
- D:\Test - файл с названием Test в корне диска D. (В некоторых программах эти правила игнорируют).

Операционная система не различает прописные и строчные буквы, поэтому надписи: D:\Programm, d:\ PROGRAMM и D:\proGRAMM она воспримет, как равнозначные.

Для выбора нужного нам файла мы можем перемещаться по файловой системе диска и открывать нужные папки:
- двойным щелчком мыши;
- выбирать папку одинарным щелчком, и открывать ее нажатием клавиши Enter.

Вот мы научились перемещаться по папкам и выбирать файлы, а что дальше? Дальше начинается самое интересное. Мы можем начать файлы исследовать. А что можно исследовать у файла? Во первых мы можем определить, что это за файл.

Все файлы делятся на две большие группы: программы и данные. Программа это набор инструкций (команд) для процессора (главного устройства любого компьютера - не путать с ящиком, который называют системным блоком).
В файлах данных хранятся результаты работы программ.

Если paint.exe это название программы графического редактора, то paint.bmp - название картинки (файла данных), которая в этом редакторе может быть создана. Конечно же название картинки может быть другим.
Если notepad.exe - название программы редактора текстов, то spravka.txt - название текстового файла (файла данных), который можно создать в этой программе. Существуют сотни разновидностей программ и сотни разновидностей файлов данных. Есть файлы программ, которые могут создавать файлы программ - языки программирования.

Вы обратили внимание, что название файла состоит из двух частей разделенных точкой. Слева от точки - имя файла, а справа от точки - расширение. Зачем это нужно? Имя кратко указывает на содержимое файла (название программы, документа, фильма). Расширение указывает на тип файла.

Как вы уже поняли, файл это просто последовательность чисел, а вот на то, что это в самом деле и указывает расширение. Если картинка то, например: . bmp, или .jpg, или .ico. Если звук (песня, музыка) то, например: .wav, или .mp3. Так по расширению операционная система определяет, что с этим файлом можно делать. Конечно же, бессмысленно загружать файл с расширением .mp3 в программу для просмотра изображений. Изначально в операционной системе не существовало жесткого требования к наличию у файла расширения, поэтому вы можете изменить расширение у файла, которое ему присваивает программа при создании, но ни к чему хорошему это, конечно, не приведет, ведь содержимое то файла останется тем же самым. Можно создать файл совсем без расширения, но тогда уж вы сами должны знать, как его использовать.
Итак, мы определили, что файл может иметь расширение и оно определяет его тип. А какие типы файлов существуют в файловой системе? Их очень много, но самые распространенные можно привести:
- .txt - простой текст (числа внутри файла интерпретируются в символы и мы видим текст).
- .htm, .html - Web-странички - то что вы сейчас читаете (почти что текст).
- .exe, .com, .dll - программы (набор инструкций для процессора).
- .jpg, .bmp, .gif, .png - файлы изображений.
- .wav, .mp3, .wma - звуковые файлы.
- .avi, .mpg, .flv - видеофайлы.

Серьезные программы проверяют тип файла по его содержимому и не будут пытаться
отображать звуковой файл в виде картинки.

Что же еще интересного мы можем узнать о файле? Очень много. Основные (главные) характеристики файла менеджер файлов показывает в правом окне. Это: Имя, расширение, размер (измеряется в байтах или килобайтах), дату создания или изменения, тип файла и атрибуты. А для просмотра полного набор характеристик файла нужно переместить на него указатель (один щелчок мыши), а затем, нажав правую кнопку, выбрать пункт контекстного меню "Свойства".
Атрибуты это указатели на принадлежность файла к группе. Обычные файлы имеют атрибут "Архивный". То есть просто хранятся на диске для обычного использования. Существуют следующие группы, к которым файл также может принадлежать (может входить в несколько групп): Системные, Скрытые, Только для чтения. Как видно из названий групп атрибут указывает на важность файла и в зависимости от его наличия операционная система может с ним работать по разному.
Важные объекты, имеющие атрибут Системный и Скрытый, в списке показываются зачеркнутыми, чтобы обычный пользователь понимал, что для него они, как будь то бы не существуют.
Возможно, вы в нескольких последних абзацах получили очень много новой, незнакомой информации, но побегав по папкам и увидев много разных файлов, вы найдете подтверждения прочитанного и у вас в голове все стройно отложится. И, в дальнейшем, ФАЙЛ вам будет представляться в виде строчки в правом окне программы NKFM с кратким
набором его основных характеристик.

Почему же так важно уметь работать с файлами? Если вы начинаете использовать возможности компьютера наиболее полно, то рано или поздно вам потребуется "вручную" разбираться с тем, что у вас в нем хранится.

Типичные ситуации:
- Просмотреть фотографии с фотоаппарата или мобильного телефона.
- Сбросить себе или наоборот кому то фотки, музыку, фильм.
- Разобрать залежи документов, которые устарели и не нужны или должны исчезнуть из вашего компьютера по другим причинам.
- Во время путешествий по просторам Интернета, часто возникает желание сохранить понравившуюся страничку или ее часть или картинку с нее. Через некоторое время в этом "изобилии" приходится разбираться или платить за это специалисту.

Итак, что же мы можем делать с файлами и для чего это нужно.

Создавать. | Документ, картинку, таблицу, WEB-страничку, программу.
Удалять. | Блок данных который принадлежал данному файлу освобождается и на это место операционная система может записывать другие данные. Удаление в корзину означает перемещение файла в специальную папку под названием Корзина, откуда он может быть восстановлен.
Просматривать содержимое. | Любой файл это набор чисел, и его содержимое можно просматривать в виде чисел или символьном.
Открывать. | Мы видим файл в виде строки в списке содержимого папки (закрытое состояние). Нажимая на выбранном (выделенном) файле Enter или делая двойной щелчок мыши, мы его открываем: - загружаем в программу для обработки (документ, текст); - загружаем для просмотра (картинка, WEB-страница), - загружаем для воспроизведения (звук, фильм, анимацию); - запускаем программу на выполнение - открываем ее для работы в ней.
Копировать. | Так как это блок данных, то можно сделать копию этого блока на другом диске или в другой папке. После данной операции будет существовать два одинаковых блока, но в разных местах.
Перемещать. | Блок данных - файл можно перенести на другой диск или в другую папку. После этой операции файл окажется в новом месте. Там, где он был раньше его не будет. Если в данном месте файл не нужен, то его перемещают.
Редактировать (изменять). | Файлы: документы, картинки, WEB-страницы, звуковые файлы и другие могут быть изменены.
Переименовывать. | Блоку данных можно дать другое имя, например: после копирования из фотоаппарата файлы имеют цифросимвольные имена, а нужно им давать осмысленные. Было: IMG001024.JPG, а стало: Портрет Васи.jpg.

Для выполнения каждой из описанных операций вам необходимо выбрать файл или папку, установив на них указатель и нажать нужную кнопку справа или соответствующую ей функциональную клавишу. Естественно, что папку мы не можем отредактировать или просмотреть, так как содержимое папки это список папок и файлов в ней размещенных.

Несколько уточнений о создании файлов.

В программе NKFM мы можем создать текстовый файл. Простой текст можно ввести с клавиатуры или вставить из буфера обмена. Файл будет создан в текущей рабочей папке, которая выбрана на правой панели. Для этого нажмите сочетание клавиш Shift и F4 (Shift нажимаем и удерживаем, функциональную клавишу F4 нажимаем кратковременно) и дайте название вновь создаваемому файлу.
Файлы других типов создаются в определенных программах, которые должны быть установлены на вашем компьютере и перед созданием файла их нужно запускать на выполнение. Например: Word, Excel, PowerPoint, Pascal, Paint, QBasic, FrontPage и так далее. После запуска нужной программы создается новый пустой файл, который вы должны наполнить содержанием и сохранить на диск в нужную папку.
Такие файлы, как фотография, видеоклип, звуковой файл могут создавать соответствующие устройства: фотоаппараты, сотовые телефоны, видеокамеры и другие.
Для дальнейшего полноценного использования эти файлы нужно скопировать или переместить на диск компьютера, а потом просматривать, прослушивать, пересылать знакомым или размещать в Интернете.

Рассмотрим подробнее список файловых операций и назначенных для них функциональных клавиш.

F2 Переименование файла или папки.
Это означает, что вы можете изменить назначенное им ранее имя по своему усмотрению. Установите указатель на нужный файл или папку и нажмите кнопку F2 в окне справа или просто функциональную клавишу F2. Появится окно со старым именем, которое вы можете изменить (конечно же имя, а не окно).
F3 Просмотр файла.
Зачем нужно просматривать файл? Выясним подробнее. Файл можно просмотреть двумя способами.
- Первый это представление его в том виде, в котором он отображается в операционной системе для обычного пользователя. То есть, картинка, как картинка, WEB-страница, так как мы ее видим в Интернете, документ WORD с красиво оформленными текстами и изображениями и так далее.
- Второй способ это просмотр именно содержимого файла. Содержимое, то есть то, что находится в том самом блоке данных, тоже можно просмотреть двумя способами.
- Первый это просмотр файла в символьном виде. В этом случае каждому числу в блоке-файле сопоставляется символ согласно таблице кодировки. В старых DOS-системах каждому числу соответствовал один символ, а в новых Windows-системах совсем другой. А с развитием Интернет используют совсем другой способ сопоставления чисел и символов - Unicode. Такой способ просмотра помогает представить файл, как текст, потому что очень много файлов разного типа, например: .htm, .bat, .cmd, .js, .vbs, .pas, .bas и много других являются по сути текстовыми, но в определенных программах они выполняют определенные функции. Просматривая их в виде текста, мы выясняем содержимое файла не загружая его в сопровождающую программу.
- Во втором случае при просмотре содержимого видят и само число в блоке-файле в шестнадцатеричной системе счисления и сопоставленный ему символ. Этот способ нужен специалистам и программистам. В таком виде можно просматривать любые файлы, в том числе и программы. В этом случае мы можем видеть, и символьное представление файла и числа-коды.
В менеджере файлов NKFM реализованы все вышеописанные способы просмотра файлов.
F4 Редактирование файла.
Содержимое любого файла может быть изменено. В программе NKFM данная операция редактирует текстовые файлы (расширение .txt), но те, которые можно представить, как текст (смотри выше рассказ про F3) тоже можно редактировать, если вы понимаете, что вы делаете. Никто вам не запретит изменять, так называемые двоичные (не текстовые файлы), но в этом случае вы должны осмысленно представлять, что в них менять можно, а что нельзя. Если вас не устраивает программа Блокнот (Notepad), то вы можете установить для выполнения операции редактирования ту, которая нравится вам, введя ее координаты в пункте меню настроек программы "Внешний редактор" - (F9).
F7 Создание новой папки.
Как говорится, новая папка она и в Африке ей же и остается. Выберите папку в которой вы хотите создать свою - новую и нажмите F7, введите ее название и размещайте в ней все, что вы захотите.

Почему я пропустил функции F5 - копирование, F6 - перемещение и F8 - удаление, потому, что они очень важные с точки зрения выполнения и понимания. Перед выполнением этих файловых операций вы должны сосредоточится и подготовиться.

Выделение Если вам нужно выполнить операцию над несколькими файлами, или папками, или над смешанной группой, то требуемые объекты (файлы и (или) папки) нужно выделить. Это можно сделать несколькими способами.
- Однократное нажатие клавиши "Пробел" помечает файл или папку, как выделенную. Указатель остается на выделенном элементе. Так удобно помечать папки: мы сразу видим ее размер на панели над правым окном. Повторное нажатие отменяет пометку.
- Нажатие клавиши Insert выполняет все то же, что и указано выше, но перемещает указатель в следующую позицию вниз. Так удобно выделять группы файлов разного типа.
- Выделение по маске: нажатие клавиши "+", например на цифровой клавиатуре, вызывает окно для ввода маски выбора файлов. Выбор по маске предполагает использование обобщающих символов * и ? Звездочка * означает использование при выборе имени любого количества любых символов. Например: *.* - означает: все файлы в выбранной папке. Test.* - все файлы с названием test с любым расширением. *.txt - выделение всех текстовых файлов с любым именем. Документ*.doc - Все файлы начинающиеся со слова Документ с расширением .doc. Знак вопроса ? означает любой один символ. ФотоN?.jpg - выделит все jpg изображения, которые начинаются словом фотоN, например все от ФотоN1 до ФотоN9.
- Отмена выделения по маске: нажатие клавиши "-", например на цифровой клавиатуре.
Удобно делать отмену выбора по маске, когда вам нужно выделить все КРОМЕ... Например, все файлы, кроме текстовых (.txt) или, кроме jpg-изображений и тд.
В программе NKFM легко выделить группу, или сделать исключение выбора, или инвертировать выбор, щелкнув по крайней правой кнопке панели инструментов.
F8 Удаление.
Рассмотрим функцию удаления, которая выполняется кнопкой F8 или этой же функциональной клавишей.
Удаление в операционной системе может происходить двумя способами: в корзину и безвозвратно. После того, как вы установили указатель на файл или папку и нажали кнопку F8 появляется окно, которое напоминает вам об объекте, который вы удаляете и просит указать, как вы собираетесь это делать в корзину или насовсем. Корзина это специальная папка, которая обозначена одноименным ярлычком, а в файловой структуре диска имеет название RECYCLED. Она имеет атрибуты скрытая и системная но в NKFM мы можем ее видеть. Из этой специальной папки (Корзины) файлы и папки можно восстанавливать открыв ее двойным щелчком мыши по ярлычку на рабочем столе, выделив нужный объект и, нажав правую кнопку. Файл, удаленный насовсем можно попытаться восстановить при помощи специальных программ, не пользуясь компьютером сразу после удаления. Но восстановление в этом случае абсолютно не гарантировано, так как операционная система интенсивно использует свободное дисковое пространство.
Если вы удаляете выделенную группу объектов и нажимаете кнопку F8 (удаление), то в этом случае программа также запросит подтверждения удаления в корзину или безвозвратно. Потом, уже операционная система будет запрашивать у вас подтверждений на удаление группы файлов, а на объекты имеющие атрибуты отличные от архивного новых подтверждений, так как эта операция очень важная и ответственная.
F5 и F6 К операциям Копирования (F5) и Перемещения (F6) необходимо подготовиться, потому, что это тоже очень серьезно. Мы должны четко осознать КАКИЕ объекты и КУДА будут копироваться или перемещаться. В двухоконных менеджерах файлов, а NKFM становится таким во время данных операций, все начинается со второго действия. Мы должны в дополнительном окне выбрать папку, КУДА мы будем помещать объекты исходные.

Итак, раз, если дополнительное окно не открыто, открываем его кнопкой на панели управления.
Два, отрываем папку назначения для объектов копирования или перемещения.
Три, выбираем требуемые файлы и папки в правом окне, так, как рассказано в пункте "Выделение".
Четыре, нажимаем кнопку Копировать (F5) или Переместить (F6).
Пять, появляется окно подтверждения команды, нажимаем Ok, если во всем уверены, и наблюдаем процесс копирования или переноса.

Если компьютер не очень шустрый, или вы выбрали очень много объектов, например, копируете с фотика несколько тысяч отпускных фотографий, то процесс может затянуться. Но в программе NKFM файловые операции выполняются средствами операционной системы, и после подтверждения команды обо всех неожиданностях во время выполнения заботится сама система. Работа в программе может быть продолжена.
Укажу на небольшую особенность: первой операцией перед копированием или перемещением
может быть выбор требуемых файлов и папок. Важно не забывать, ЧТО мы выбираем и КУДА будем помещать.

Используя программу файловый менеджер NKFM, вы очень быстро поймете, как устроена файловая структура дисков, научитесь осознанно и уверенно работать с файлами, а значит я свою задачу буду считать выполненной.

Дальше я расскажу об особенностях и удобствах моего файлового менеджера, но если у вас хватило сил одолеть вышеописанный материал, то можно считать, что фундамент уверенного компьютерного пользователя у вас есть.

- Управление списками на панелях производится кнопками, которые расположены слева на панели инструментов.
Список с нижней панели на верхнюю
Список с верхней панели на нижнюю.
Обменяться списками между панелями.
- Менеджер NKFM сохраняет функциональность Проводника. Нажмите на выбранном объектке правую кнопку и в контекстном меню выберите необходимую операцию с ним, которую обеспечивает операционная система.
- При обилии информации NKFM поможет в поиске нужного файла по большому количеству критериев - кнопка "Искать".
- В менеджере файлов NKFM реализован просмотр содержимого файлов любого размера в наиболее употребимых кодировках (WIN, DOS, UNICODE). Окно просмотра удобно располагается справа от программы и открывается или убирается кнопкой [<>].
- Встроенный просмотрщик поддерживает просмотр распространенных форматов изображений (BMP, JPG, GIF, PNG, WMF, ICO).
- При потребности в ручном формировании команд запуска программ используй "Выполнить". Ctrl-J - команда в строку из списка.
- Несколько шелчков и движений мышью и мы имеем привычные два окна, но расположить мы их можем, однако же, как захотим.

Краткая информация для использования программы "Менеджер файлов NKFM".

- Диск выбирается из списка левого окна или из выпадающего списка дисков.
- Общий объем и наличие свободного пространства на выбранном диске отображаются.
- Выбор необходимой папки можно производить, как в левом так и в правом окне. При работе с правой панелью левая отслеживает положение выбранной папки.

 Другие функциональные клавиши

F9 - Задание особых настроек:
1. Внешний просмотрщик для текстов.
2. Внешний просмотрщик для изображений.
3. Внешний редактор текстов (Если вы не хотите использовать Блокнот).
4. Установка размера шрифта панелей списков.

F10 - Выбор программ для открытия файлов с соответствующими расширениями (Вспомните, как Windows упорно загружает файл в программу известную только ему самому, скрывая настройку где то в гуще своих дебрей). (Настройка действует только при работе с NKFM)

- Двойной щелчек левой кнопкой мыши на выбранном элементе означает его открытие программой согласно его расширения, либо выполнение, если это программа, либо открытие списка содержимого, если это папка.
- Переход в папку предыдущего уровня можно выполнить, щелкнув кнопку-указатель на панели инструментов или, нажав кнопку BackSpace (стрелка влево) на клавиатуре.
- Менеджер NKFN автоматически не корректирует список дисков на левой панели в случае активации новых (flash, сетевые) из-за медленного выполнения системой данной операции для не очень новых компьютеров. Для обновления списка дисков на левой панели нажмите вторую кнопку на панели инструментов. (Список дисков на панели инструментов обновляется автоматически).
- Для выполнения операции копироваеия или переноса необходимо открыть вторую панель кнопкой. Этой же при ненужности ее можно и свернуть.
- Для удобства все элементы снабжены всплывающей подсказкой: подведите к нему указатель мыши.
- Список в правом окне может быть отсортирован: по имени (по умолчанию), по размеру, по дате, по типу. Щелкните по заголовку соответствующей колонки. Активность сортировки отражается "галочкой".

- Списками на правой и нижней панелях можно управлять кнопками.
Реакции кнопок:
Список с нижней панели на верхнюю
Список с верхней панели на нижнюю.
Обменяться списками между панелями.

- Остальные кнопки на панели:

- Выйти из программы (должна быть всегда под рукой).
- Принудительно обновить список дисков и папок левой панели (В операционной системе могут монтироваться новые диски (флеш, сетевые), создаваться новые папки. Структура дерева файловой системы актуальна только сразу после обновления.)
- Открыть или закрыть дополнительную панель со списком папок и файлов (Если вы не собираетесь выполнять операции копирования и переноса, то она может быть закрыта).
- Свернуть или развернуть левую панель дерева файловой структуры (Правая панель со списком папок и файлов полностью функциональна, включая выбор рабочего диска).
- Кнопка перехода на один уровень в файловой стркутуре (переход в верхнюю папку, можно использовать клавишу <- BackSpace)
- Кнопка показа-скрытия панели просмотра файлов [<>]. На мониторах с широким экраном есть много места для удобного просмотра файлов изображений или содержимого файлов в текстовом или шестнадцатеричном виде.
- Кнопка информации о программе.

Программа оперативно информирует пользователя о выполняемых операциях и о событиях в системе: смена дискового носителя, изъятии диска, монтировании новых дисков.

Буду рад, если моя программа поможет вам в освоении современных компьютерных технологий. Отзывы, пожелания и конструктивная критика приветствуется.

Автор программы NKFM - Коротков Николай
Мой E-mail : kornil1956@rambler.ru

Мои сайты:
 http://nk-inform.narod.ru
http://navoloky.narod.ru